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Introduction

This course moves beyond the basics of word 
processing and covers more advanced features of the 
OpenOffice.org software.  Most of these features are 
also present, in one form or another, in other major 
word processing packages, but the details may differ. 
Obviously, it is not possible to cover every feature in 
such a short class, so I've attempted to choose some of 
the most useful ones, beginning with features that I 
use regularly in documents I create, such as these 
handouts, library newsletters, and so forth.

Frames

Think of frames as simple containers, rectangular boxes that you can put things in.  Frames can have 
visible borders, like the sidebar at the right above, or the edges can be left blank, so that when the 
document is printed you only see the contents.  In the latter case, a key advantage of putting something 
in a frame is that it makes it easy to control positioning.  Simply drag the frame to a new location, and 
the contents go along with it.  You can put anything into a frame that you can put in a document: 
images, paragraphs of text, tables, columns, even other frames.

To add a frame to your document, pull down the Insert menu and choose Frame.  A frame dialog box 
will come up, which allows you to specify some options for the frame, but if you just click "OK", a basic 
frame will be inserted.  If you later need to get back to the options, simply double-click the edge of the 
frame, and the frame dialog will reappear.  Across the top of the frame dialog are several tabs, each of 
which contains the controls for a different aspect of the frame's appearance or behavior.  For instance, 
the Wrap tab controls how the rest of the content of the document will wrap around the edges of the 
frame.  New frames start with a basic thin black border, but you can change this in the Borders tab.

When I'm doing newsletters, I put practically every article in a frame, so that I can easily move them 
around to different positions, to find the places where they fit into the layout best.  Positioning and 
changing the wrap properties for frames is very similar as for images.

Images

What would a modern office document be without clip 
art?  Putting a picture into your document, assuming 
you have the picture on your computer, is as easy as 
pulling down the Insert menu and selecting Picture 
(or, in older versions, Graphics), From File, finding 
your picture in the file-open dialog box that comes up, 

and clicking the open button. 
Once you have the 

image in your 
document, you can resize it and reposition it.  Perhaps more 
interestingly, if you double-click the image, the Graphics dialog box 

appears, which allows you to change a number of useful options. 
Under the Wrap tab, for instance, you can control how the rest of 
the document's contents will wrap around the edges of the image. 
The image at left is set up for contour wrapping, which allows text 
to overlap into transparent parts of the image.

Where can I get 
OpenOffice.org?

The software used in this course is 
freely available.  Here are some places 
you can get the software:

• http://www.openoffice.org/
(This is the official website.)

• http://www.theopencd.org/
• http://distribution.openoffice.org/cdrom/
• http://www.tradeswest.ca/ooo_order.html

Where can I get clip art?
Here are some places you can download 
clip art that you can use in your 
documents:

• http://www.openclipart.org/
• http://commoncontent.org/
• http://pics.tech4learning.com/
• http://www.pcbypaul.com/wpclipart/
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Another important setting for an image in a word processing document is where it is set to anchor.  If 
you anchor an image to the paragraph, then it will move if the paragraph moves, but if you anchor it to 
a frame or a page, then paragraphs can come and go, but the image will stay put.  To change where an 
image is anchored, select the image, then right-click it, and use the Anchor submenu.

Tables

Simple tabular information can be entered using tabs, but sometimes 
things are too complex for that (for instance, when the text in one table 
position may wrap onto a second line), and a table is useful in these 
cases.  Tables also allow for borders between the rows and columns. 
(Unlike frames, however, tables are not easily dragged around for 
positioning, so if you want easy positioning, place the table inside a 
frame, as in the example at right.)

To add a table, pull down the Insert menu and choose Table.  An insert table dialog box will appear, 
which allows you to choose some options.  The most important thing to set here is the number of 
columns.  Once your table is inserted, you can add content to each of the cells.  You can move to a 
particular cell by clicking in it, or you can move to the next cell by hitting the tab key.  If you hit the tab 
key from the last cell in the lower-right corner, a row will be added.

To adjust the properties of the table or of certain cells, highlight the cells, then right click and choose 
"Table" from the context menu.  In the resulting dialog box, you can change several properties of the 
table's cells, most notably the borders.

Table rows will automatically grow in height to accommodate the information you place in them 
(unless you turn off this feature, by selecting the cells, right-clicking, choosing Row Height, and turning 
off Fit to size).  The easiest way to resize column widths is to drag the boundaries left or right. Table 
cells can contain most things a document can contain, including images and frames.

Columns

Columns allow content to be placed side-by-side, without the need 
for hand-positioning frames.  Also, unlike with (most 
implementations of) frames, an article may flow from the end of one 
column automatically to the beginning of the next column, much like 
in a newspaper.

Some objects, including images and frames, are allowed to cross over 
column boundaries.

If you want your entire document to be laid out in columns, pull down the Format menu and choose 
Page, then look for the Columns tab.  Here you can set the number of columns per page, as well as 
change their spacing.  Normally you will want at least some spacing between the columns.

If you don't want your entire document to be structured in columns, you can still have columns in 
certain places, by using frames.  Any frame can have columns in it.  To set up a frame with columns, 
double-click the edge of the frame to bring up the Frame dialog box, and click the Columns tab.  Here 
you can make the same sorts of adjustments as before, only they will apply just to the selected frame.  

If you want to fill a certain page with columns, insert a frame, resize the frame to take up that entire 
page, and then set up the columns for that frame.

Month Days
January 31
February 28-29

March 31

Text will 
flow from 
the end of 
each 
column 
onward to 

the top of 
the next 
column. 
Separator 
lines are 
optional.
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Character Formatting

You've probably used some character formatting already, perhaps without even knowing that it was 
character formatting you were using.  If you've ever made a word bold, underlined some text, or 
changed the font face or size, you've done character formatting.  However, there is a lot more that can 
be done than just these basic things.

Did you know that there are different types of underlining?  Select some text, then pull down the 
Format menu and choose Character.  

Under the Font Effects tab you will find a drop-down list that shows the different types of underlining 
available:  single, double, bold, dotted, dotted bold, dashed, dashed bold, long dash, wave, bold wave, 
double wave, or  various other variations and patterns.  Additionally, there is a checkbox for 
underlining each word individually and a place to set a different color for the underline.

The Font Effects tab is also where you can set the color of the text itself, add transformation effects 
(such as SMALL CAPS), or cause the text to appear engravedengraved, embossedembossed, outlined, or shadowedshadowed.  These are 
not effects that you're likely to use very often, but they can come in handy occasionally.

Another, more advanced type of character formatting is positioning.  Positioning is useful for changing 
the way words fit onto the page.  This is especially useful when you are working with columns, because 
longer words can cause certain lines to wrap at undesirable places and look "funny".  You can 
hyphenate words, of course.  Indeed, you can insert optional hyphens (hold ctrl while typing the 
hyphen) that will only appear if a line breaks there, and you could even resort to automatic hyphenation 

(pull down Format, choose Paragraph, and find 
Hyphenation under the Text Flow tab), but 
hyphenation can be ugly, especially if it's 
overdone.  Sometimes what you really want is to 
squeeze or stretch certain words, to make them 
wider or narrower, so that they fit better.  This is 
positioning.  Select the word(s) you want to alter, 
pull down the Format menu, and choose 
Character.  Under the Position tab there are two 
ways to squeeze or stretch your text.  The first way 
is to simply scale the width of the text, which 
causes the actual letters to be squeezed or 
stretched.  The second, more subtle way is to 
expand or condense the spacing.  Change the 
spacing to either expanded or condensed and set 
the amount.  (1 pt is a typical amount, but you can 
use more or less depending on the needs of your 
document.)  The sidebars at the left and right 
show what Verdana 12pt and Georgia 13pt text 
look like with various settings.  Condensing a long 
word so that it fits often looks better than 
hyphenating it, and expanding some words can 
make an otherwise short line look less empty.

Besides stretching and squeezing the text, you can also ro
t- ate it or make a superscript or subscript.  Pull down 

the Format menu, choose Character, and look under the Position tab for these settings.

Normal 
(Georgia 13pt)

wide 
(150%)

wide 
(200%)

Narrow (75%)

Narrow (50%)

Expanded (1pt)

E x p a n d e d 
( 2 p t )

Condensed (0.5pt)

Condensed (1pt)

Normal 
(Verdana 12pt)

wide 
(150%)

wide 
(200%)

Narrow (75%)

Narrow (50%)

Expanded 
(1pt)

Expanded 
( 2p t )

Condensed (0.5pt)

Condensed (1pt)
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Word Processing System Translation Chart:

Desired 
Action

OpenOffice or 
Star Office

Microsoft Office / 
Word

Corel 
Word Perfect

insert a frame 
or text box:
(A frame and a 
text box are 
basically the 
same thing.)

Pull down the Insert menu 
and choose Frame, then 
drag the frame to where 
you want it to go.

Pull down the Insert menu 
and choose Text Box, then 
click where you want the 
text box to go.  For the 
most part you can ignore 
the larger “drawing area” 
box.

Pull down the Insert menu 
and choose Text Box, then 
drag the text box to where 
you want it to go

Place text in a 
frame or text 
box:

Click in the frame, and 
start typing.

Click in the Text Box, and 
start typing.

Click in the Text Box, and 
start typing

Change the 
properties of a 
frame or text 
box:

Click the frame to select 
it, then pull down the 
Format menu and choose 
Frame.

Click the text box to select 
it, then pull down the 
Format menu and choose 
Text Box.

Click the edge of the text 
box to select it, then right-
click on the text box and 
use the context menu. 

Add a picture 
you have on 
your computer:
(The picture will 
go where the 
cursor is.)

Pull down the Insert 
menu, choose Picture (or, 
in old versions, Graphics), 
then From File.    Find the 
picture file that you want 
and click Open.

Pull down the Insert 
menu, choose Picture, 
then From File.  Find the 
picture file that you want 
and click Insert.

Pull down the Insert 
menu, choose Graphics, 
then From File.  Find the 
picture file that you want 
(only certain image file 
formats are supported), 
and click Insert.

Change the 
wrap properties 
of an image:

Double-click the image, 
and select the Wrap tab.

Double-click the image, 
and select the Layout tab.

Click the image to select 
it, then right-click the 
image and choose Wrap 
from the context menu.

Add a table: 
(The table will 
go where the 
cursor is.)

Pull down the Insert menu 
and choose Table.  Set the 
number of columns and 
click OK.

Pull down the Table menu 
and choose Insert, then 
Table.  Set the number of 
columns and click OK.

Pull down the Table menu 
and choose Create.  Set 
the number of columns 
and click OK.

Print sideways 
on the paper:

Pull down the Format 
menu and choose Page. 
Under the Page tab, select 
Landscape.

Pull down the File menu 
and choose Page Setup. 
Under the Margins tab, 
select Landscape.

Pull down the File menu 
and choose Page Setup. 
Under the Page Setup tab, 
select Landscape.

Add a header 
or footer:

Pull down the Format 
menu and choose Page. 
Click the Header or Footer 
tab and turn on the 
checkbox.

Pull down the View menu 
and choose Header and 
Footer.  Edit your header 
or footer and then Close 
the Header and Footer 
dialog.

Pull down the Insert menu 
and choose 
Header/Footer.  Select the 
one you want and click 
Create.

Set up columns 
for your entire 
document:

Pull down the Format 
menu and choose Page. 
Under the Columns tab, 
set the number and 
spacing of columns.

Pull down the Format 
menu and choose 
Columns.  Set the number 
and spacing of columns.

Pull down the Format 
menu and choose 
Columns.  Set the type, 
number, and spacing of 
columns.


